jQuery Updater – WordPress plugin WordPress插件下载

点击下载

jQuery Updater

插件描述

此插件将 jQuery 更新为最新的官方稳定版本,这是最多的可能在WordPress的最新稳定版本中无法使用。
由于此插件中使用了jQuery 2+,因此jQuery 1.x已过时,还包括 jQuery Migrate

没有文件被替换,因此停用此插件会使您的网站恢复原状。

警告

如果您不熟悉beta测试,错误修正,javascript或正在运行的前沿软件,建议不要
我不会在JavaScript和jQuery上提供帮助!

报告问题

请在 WordPress.org支持论坛上发布错误报告和请求帮助。我只会提供有关插件引起的问题的帮助,而不是JavaScript和jQuery相关的问题!
请在 GitHub问题页面上报告功能请求和代码更改

如果您遇到任何错误,关闭此插件将完全停用所有内容。

正在进行中

选项屏幕启用/禁用选项以选择特定的jQuery版本自动缓存刷新

有关开发的更多信息,请访问插件 GitHub

2.2.0.1

更新了jQuery迁移到1.3.1删除了未使用的文件

2.2.0

准备好核心转换将jQuery更新为2.2.0 替换了注释使用PHPDocRemoved一些未使用的文件

2.1.4

将jQuery更新为2.1.4Updated自述文件

2.1.3

将jQuery更新为2.1.3修复了jQuery的错误迁移不正确loadingUpdated mini将WordPress的版本修改为3.9删除了一些单元测试脚本

2.1.1

将jQuery更新为2.1.1

2.1.0

将jQuery更新为2.1.0

2.0.3

更新jQuery到2.0.3更新 jQuery迁移到1.2.1改进的文档包含常见问题解答和删除的屏幕截图。 (谁想看到javascript的截图?)添加了jQuery 1.x作为fallbackFallback:将jQuery更新为1.10.2由于WordPress 3.6这个插件无法破坏仪表板。

2.0.0.1 / 2.0.0.2

添加 jQuery Migrate

2.0.0

jQuery 2.0与jQuery 1.9具有相同的API,但不支持Internet Explorer 6,7或8. jQuery 1.9升级指南中的所有注释也适用于此处。由于IE 6/7/8仍然比较常见,我们建议使用1.x版本,除非您确定没有IE 6/7/8用户访问该站点。

将jQuery更新为2.0.0 releasenotes

1.9.1

将jQuery更新为1.9.1 releasenotes

1.9.0

将jQuery更新为1.9.0

1.8.3

将jQuery更新为1.8.3改进的代码样式和文档

1.8.2

将jQuery更新为1.8.2修复了DashboardMinor代码改进中的错误

1.8.1

将jQuery更新为1.8.1

1.8.0

将jQuery更新为1.8.0 releasenotes

1.7.2

将jQuery更新为1.7.2Readme修复

1.7.1

将jQuery更新为1.7.1 releasenotes 次代码优化自述更新

1.7.0

将jQuery更新为1.7 releasenotes 自述文件updateMinor代码优化

1.6.4

将jQuery更新为1.6.4 releasenotes

1.6.3

将jQuery更新为1.6.3

1.6.2.1

将jQuery更新为1.6.3 rc 1(缩小)

1.6.2

更新了jQu变为1.6.2(缩小)

1.6.1.1.1

承诺:当1.6.2出现时更少的数字更新jQuery到1.6.2 rc 1(警告测试版:未明确,无冲突

1.6.1.1

添加jQuery.noConflict() ;为兼容性的javascript文件

1.6.1

将jQuery更新为1.6.1

1.6.0.1

jQuery 1.6.1 rc 1(修复已知的WP错误,直到3.2发布)

1.6.0

等于1.1.2但与jQuery相同的数字

1.1.2

jQuery 1.6.0

1.1.1

从插件目录加载javascript而不是google服务器。

1.1.0

将jQuery 1.5.2.min添加到javascript目录中将jQuery UI添加到单独的插件

1.0.1

将jQuery UI更新为1.8.12(在Googles CDN上)已修复版本1..0(应为1.0)

1.0

第一个版本,在Googles CDN上使用jQuery 1.5.2

安装

上传 jquery-updater / / wp-content / plugins / 目录通过WordPress的“插件菜单激活插件坐享

常见问题解答

问:我需要这个插件,如果我真的运行最新版本的WordPress的在我的网站?
A:否

问:这个插件是否与PHP 5.2 / 5.3 / 5.4 / 5.5 / 5.6或7和HHVM兼容?
A:是

问:这个插件破坏了我的网站!我如何解决它?
答:使用jQuery版本2可能会破坏您的网站。请参阅此插件主页上的警告。

评论

发表评论

邮箱地址不会被公开。 必填项已用*标注