SyntaxHighlighter Evolved – WordPress plugin WordPress插件下载

点击下载

SyntaxHighlighter Evolved

插件描述

现在支持WordPress 5.0中的新块编辑器!

SyntaxHighlighter Evolved允许您轻松地将语法突出显示的代码发布到您的站点,而不会丢失其格式或进行任何手动更改。它使用Alex Gorbatchev SyntaxHighlighter JavaScript包。

有关现场演示,请参阅此插件的主页

有关支持的语言列表(支持最常用的语言),请参阅 WordPress.com支持文档

如WordPress.com所示。

屏幕截图

某些PHP代码的示例显示。
编辑块的使用示例。

FAQ

代码只是原始显示。它没有被转换成代码框或任何东西。怎么了?

确保主题的 footer.php 文件有<?php wp_footer(); ?> 在其中的某个地方,否则插件将无法做到这一点。

突出显示不起作用,我的浏览器挂起,为什么?

尝试从您的网站可能正在进行的任何性能优化中排除此插件的Javascript,这涉及缩小或连接JS。

评论

发表评论

电子邮件地址不会被公开。 必填项已用*标注