Woody ad snippets – insert any code, text, or ads via using conditions – WordPress plugin WordPress插件下载

点击下载

Woody广告片段 – 使用条件插入任何代码,文字或广告

插件描述

不要一遍又一遍地重复使用相同的内容再次!停止向function.php插入PHP代码!停止将google analytics,yandex指标和外部代码添加到页眉和页脚php文件中!停止浪费时间更改100页重复内容!

Woody广告片段将让您的生活变得更加轻松。该插件有助于在您网站的管理栏中的特殊库中创建和存储代码段或重复文本。使用短代码在您的网站上的任何位置添加代码段。或者自动进行,例如:头部,页脚和后注射。您可以使用条件逻辑显示或隐藏代码段。

为什么需要这个插件?

插入页眉和页脚在您的网站上插入Google AdSense广告,亚马逊原生购物内容相关广告,Yandex直接广告,Media.net。插入Google Analytic Tracking代码,Yandex Metrica跟踪代码,Yandex计数器到页眉,页脚。插入PHP代码段并在您的网站上执行。在任何地方注册PHP函数,类,全局变量。插入社交媒体小部件,添加任何外部资源小部件。插入Facebook像素,Facebook脚本,Facebook og:图像标记,谷歌转换像素,Vk像素。显示或隐藏基于条件逻辑的代码片段。您可以保存帖子或页面构建器,引号和库的模板,以便在您的网站上重复使用它们。

如何运作?

示例#1

您创建了一个新的JavaScript代码段并添加了您想要放在网站上的代码。 Html代码段编辑器为您提供工具提示并突出显示语法错误。现在您需要定义放置代码的位置。例如,您可以将代码放在所有页面的页眉,页脚中。这适用于Google Analytics。创建一个addit条件:不向管理员显示此代码。它将阻止跟踪用户角色。

示例#2

您可以创建文本片段并添加重复的文本或模板。您可以为联系表单添加一个短代码,以防所有网站页面都是通用的。现在,您可以添加条件以仅向注册用户显示此内容。保存文本片段并转到编辑页面。如果您使用Gutenberg编辑器,则需要选择一个特殊单位。对于经典编辑器,请单击我们插件的图标,然后添加新代码段的短代码。
正如您所看到的,使用代码片段非常简单!

所有插件功能:

页眉页脚代码管理器用户友好的代码编辑器,语法高亮显示。使用经典的WordPress编辑器创建富文本广告TinyMCE.Use短代码将一个片段放在网站的任何位置。使用特殊的单位在Gutenberg Editor中添加一个片段。您可以使用短代码或特殊单元(Gutenberg编辑器)将内容和其他属性发送到片段。在所有页面上自动发布帖子片段。运行PHP代码到处或某个短代码。使用用于创建代码片段的JavaScript,CSS和HTML代码。无限数量的代码片段。使用其他插件的短代码。显示或隐藏基于条件逻辑的代码片段。导出/导入代码片段。

您可以在哪里自动放置代码段?

所有网站:

在所有页面上插入页眉和页脚:

插入页眉 – 代码段添加到源代码中< / head>之前的标题tag.Insert Footer – 代码片段在< / body>之前添加到页脚的源代码中标签。

插入帖子,页面,自定义帖子:

插入广告之前帖子 – 帖子片段添加到< / head>之前的源代码中tag.Insert ads Before Content – 页面片段已添加在帖子/页面内容之前。插入广告在段落之前 – 在特定段落之前添加帖子片段。位置编号字段中列出了段落编号。插入广告后段落 – 在特定段落后添加了帖子片段。在“位置编号”字段中列出了一个段落编号。插入广告内容后 – 在帖子/页面内容之后添加页面片段。插入广告后在帖子/页面后添加帖子后片段。

插入到类别,档案,标签,分类:

在摘录前插入AdSense – 在帖子/页面预览之前添加了摘要。插入AdSense摘录后 – 在帖子/页面后添加了摘要预览。在帖子之间插入AdSense – 在帖子之间添加了代码段。插入AdSense之前的帖子 – 在某个帖子之前添加了代码段。邮政编号列在“位置编号”字段中。插入AdSense后发布 – 在某个帖子后添加了代码段。邮政编号列在“位置编号”字段中。

什么是显示片段的条件逻辑选项?

页面类型;设备类型;帖子类型;分类;用户角色;包含cookie;用户来自何处;用户的注册日期。

推荐我们的插件

Clearfy – 一体化优化工具 Robin Image Optimizer – 节省图像压缩费用

需要支持,我们为您提供了支持

我们为此插件提供免费支持。如果您遇到问题,只需创建一个新票证即可。我们一定会帮到你!

开始免费支持 文档

我们非常需要您的帮助翻译Woody广告片段将插件插入您的母语。我们希望使其成为国际化的,并为每个人所理解。请通过插件内的电子邮件与我们联系,或在我们的支持论坛如果您可以帮助翻译。为了您的帮助,我们将为您提供更好的支持和我们的高级插件完全免费!

历史,开发人员,积分

如果您是长期用户,可能会对新插件更新感到困惑。你一直在使用一个旧插件 – 插入php 1.3.0,现在有一个扩展产品 – 伍迪广告片段。 Insert php是第一个使用PHP代码的插件版本。它由Will Bontrager Software,LLC创建。在2018年,Webcraftic工作室开始积极开发插件。我们已经创建了一个路线图并发布了几个强大的更新,可以帮助您更舒适,更安全地使用PHP代码。现在,插件不仅支持PHP,还支持其他代码段类型。我们决定将插件重命名为Woody广告代码段。此名称更适合新的和强大的插件功能。

有关插入PHP插件的更多信息,请访问:

http://www.willmaster.com/software/WPplugins/go/iphphome_iphplugin

屏幕截图

代码段列表
编辑php代码段
编辑文本片段
设置片段的自动放置
设置条件逻辑以显示代码段
为Gutenberg编辑器创建代码段
将片段短代码添加到文本小部件

安装

将插件文件上载到

/ wp-content / plugins / plugin-name 目录,或者安装plugi n直接通过WordPress插件屏幕。

通过激活插件WordPress中的“插件”屏幕

使用PHP代码段 – >添加代码段,以创建新代码段

常见问题解答

如何使用短代码将属性传递到代码段?

向短代码添加新属性“simple”[wbcr_php_snippet id =“xx”simple =“example”]。

片段中提供属性“simple”作为$ simple变量。属性名称可以包含拉丁字母和小写数字。您也可以使用下划线。

由于错误而执行的代码段代码我无法更改它,我该怎么办?

不要绝望!即使是有经验的人也会犯错误。我们为这种情况创建了一个安全模式。进入它,您的代码片段代码将不会被执行。

通过以下链接进入安全模式:http://your-site-name.dev/wp-admin/?wbcr-php-snippets-safe-modeEdit您犯了错误的片段;保持安全模式点击链接:http://your-site-name.dev/wp-admin/?wbcr-php-snippets-disable-safe-mode

太棒了,现在你不应该有任何问题!

如何将网页内容传递给代码段?

我们经常想在特定页面上隐藏文本或表格的一部分并设置显示条件。您需要将要传递的内容包装为包含短代码的片段[wbcr_php_snippet id =“xx”simple =“example”]页面内容[/ wbcr_php_snippet]。代码段中的网页内容位于$ content变量中。

插件是否支持Gutenberg编辑器?

是的,确实如此。你可以从我们的插件中添加特殊的块。

我使用旧的插件插入php 1.3.0。在2.x.x版本中我应该期待什么?

旧版本的Insert php 1.3.0以这种方式工作:你用短代码[insert_php] php代码[/ insert_php]包装PHP代码。从版本2.x.x及更高版本开始,您需要创建特殊的代码段来放置PHP代码。使用片段短代码[wbcr_php_snippetid =“xx”]而不是短代码[insert_php] [/ insert_php]在页面上执行PHP代码。

我们建议您将所有代码从帖子编辑器移到代码段。

重要! TinyMCE将双引号转换为特殊字符。因此,如果您将此代码放在代码段编辑器上,它可能无法正常工作。要避免此问题,请使用经典双引号替换PHP代码中双引号的所有特殊符号。

您计划支持旧版本1.3.0多长时间?

60%的用户已经下载了2.x.x版本。我们正努力达到80%的数量。支持截止日期定于2019年3月1日。

您可以从

这里下载旧的插件版本。 我不喜欢新的插件版本。如何回滚到1.3.0并且没有获得更新?

首先,请花一些时间来实际阅读新版本。通常,需要一周时间才能看到此版本对您有多大用处。如果您遇到任何问题或发现了一些错误,请随时通过我们的

支持论坛与我们联系。

您始终可以从

下载旧版本(1.3.0)。

为避免更新,请打开PHP文件wp-content / plugins / insert-php / insert_php.php并将插件版本更改为9.9.9。

有没有插件文档?

您可以在

中找到详细的文档。 插件是否与GDPR兼容?

是的,该插件与GDPR完全兼容。

可以完全卸载插件吗?

转到设置页面并启用“完全卸载”选项。当你使用WordPress中的“插件”菜单删除Woody广告片段时,它将清理数据库表和一些其他数据。除非您希望这样做,否则请小心不要删除插件菜单中的Woody广告代码段。

如何通过ftp客户端删除插件?

哟你必须删除插件的文件夹,它位于:wp-content / plugins / insert-php

这不会清除数据库中的插件数据。您必须通过管理面板删除插件并启用“完全卸载”选项才能完全清除插件数据。

如果我更改主题或升级WordPress,我会丢失我的片段吗?

不,这些片段存储在WordPress数据库中,与主题无关,不受WordPress升级的影响。

插件是否适用于多站点?

该插件不支持多站点。

我们一定会在未来增加多站点支持。您可以通过我们的

支持论坛发出请求来加快此过程。

评论

发表评论

电子邮件地址不会被公开。 必填项已用*标注