YITH WooCommerce Ajax Product Filter – WordPress plugin WordPress插件下载

点击下载

YITH WooCommerce Ajax产品过滤器

插件描述

按您要查找的特定产品过滤

功能强大WooCommerce插件:WooCommerce产品过滤器小部件,WooCommerce Ajax产品过滤器允许您应用所需的过滤器来显示您正在寻找的产品的正确WooCommerce变体。
选择颜色,标签,列表和下拉列表,您的WooCommerce过滤搜索将显示那些完全符合您需求的特定产品。
一个非常有用的WooCommerce插件,可以帮助客户找到他们真正想要的东西。
所有这一切都可以通过快速而直观的方式完成,这无疑将帮助您的WooCommerce商店提高质量和可用性。

YITH WooCommerce Ajax产品过滤器的工作演示可在此处获取:
现场演示

YITH WooCommerce Ajax产品过滤器的完整文档是可用这里

YITH WooCommerce Ajax产品过滤器的主要特点:

使用YITH WooCommerce过滤WooCommerce产品Ajax产品过滤器小部件(可提供4种布局)ListDropdownColorLabel使用YITH WooCommerce Ajax重置过滤器小部件重置所有应用过滤器

YITH WooCommerce Ajax产品过滤器的高级功能:

YITH WooCommerce Ajax产品过滤器小部件(BiColor,标签)的两个额外布局,以及与插件YITH WooCommerce BrandsCustomizable重置按钮的兼容性(在YITH WooCommerce Ajax中)重置过滤器小部件)WooCommerce搜索过滤器,用于特定价格范围的产品,这要归功于YITH WooCommerce Ajax列表价格筛选小工具搜索过滤器,用于销售产品/ availableAjax排序页面中显示的产品(按费率,价格,人气,最新)上传图标作为自定义加载器自定义WooCommerce价格过滤器小部件

YITH WooCommerce Ajax产品过滤器可与 YITH Essential Kit for WooCommerce#1中的许多其他插件结合使用 ,一系列不可或缺的工具,使您的WooCommerce网站看起来更专业,更友好。了解有关所有WooCommerce插件的更多信息,只需点击一下即可提升您的WooCommerce网站!

与WooCommerce插件的兼容性

YITH WooCommerce Ajax产品过滤器已经过测试,并且您可以将以下WooCommerce插件与您的网站进行兼容:

YITH WooCommerce Multi供应商 YITH WooCommerce Brands Add-On YITH产品尺寸图表WooCommerce

尽管如此,它可能与尚未经过测试的许多其他WooCommerce插件兼容。如果您想通知我们与其他插件的兼容性,请发送电子邮件给我们

译员

可用语言

英语(默认)Italiano

如果您已创建自己的语言包,或者对现有语言包进行更新,则可以发送 gettext PO和MO文件
使用,因此我们可以将其捆绑到YITH WooCommerce Ajax导航语言中。

文档

完整文档此处

屏幕截图

Admin – Appearance – >窗口小部件:WooCommerce过滤器窗口小部件列表样式
管理员 – 外观 – >小部件:WooCommerce过滤器小部件颜色样式
管理员 – 外观 – >小工具:WooCommerce过滤小工具标签样式
管理员 – 外观 – >小工具:WooCommerce过滤小工具下拉样式
管理员 – 外观 – >小部件:WooCommerce过滤重置按钮
前端:侧边栏中的WooCommerce小部件
前端:下拉样式
前端:重置按钮和活动过滤器
管理员:YIT插件 – > Ajax产品过滤器 – >前端
管理员:YIT插件 – > Ajax产品过滤器 – >自定义样式

安装

解压缩下载的zip文件。将插件文件夹上载到WordPress站点的 wp-content / plugins / 目录中。激活 YITH来自插件页面的WooCommerce Ajax产品过滤器

常见问题

为什么我的侧边栏中没有显示小部件?

要显示窗口小部件,您需要将其分配到“商店”页面的侧边栏,还需要将WooCommerce产品属性添加到产品中。阅读文档的“入门”部分以了解如何添加它们。

版本2.0.0的翻译问题

尊敬的用户,
我们想通知您,插件YITH WooCommerce Ajax Navigation将在下次更新时将其名称更改为YITH WooCommerce Ajax产品过滤器。
除了名称,新版本的插件,textdomain也将从“yit”更改为“yith_wc_ajxnav”。
此更改解决了您在过去几周中发现的某些翻译/多语言插件所产生的文本域冲突问题。
它可能的是,通过插件更新,WordPress将无法识别某些语言文件。在这种情况下,您只需要使用正确的格式重命名语言文件,将旧文本域更改为新文本域。
例如,如果您的语言文件名为yit-en_GB.po和yit-en_GB.mo,则只需将它们分别重命名为yith_wc_ajxnav-en_GB.po和yith_wc_ajxnav-en_GB.mo。
重命名文件后,您可以按照经典的翻译程序更新/翻译.po文件。

版本2.4.0的翻译问题

最近,YITH WooCommerce Ajax产品过滤器被选中包含在“translate.wordpress.org”翻译程序中。为了在新系统中正确导入插件字符串,我们不得不将文本域格式’yith_wc_ajxnav’更改为’yith-woocommerce-ajax-navigation’。一旦插件将在translate.wordpress.org系统中导入,其他语言的翻译将直接从WordPress下载,而不使用任何.po和.mo文件。此外,用户将能够以更直接的方式参与插件翻译,并在translate.wordpress.org的专用标签中以其语言建议文本。在此转换步骤中,.po和.mo文件将一如既往地使用,但为了被WordPress识别,他们需要有一个新的命名法,将它们重命名为:yith-woocommerce-ajax-navigation-.po yith -woocommerce-ajax-navigation-.mo。例如,如果您的语言文件名为yit-en_GB.po和yit-en_GB.mo,则只需将它们分别重命名为yith-woocommerce-ajax-navigation-en_GB.po和yith-woocommerce-ajax-navigation- en_GB.mo。

单击WooCommerce过滤器后页面不会更新

问题可能与您使用WooCommerce商店页面的非标准模板有关。要解决它,你应该问问主题的作者使用WooCommerce标准HTML类。
作为替代:
对于2.2.0之前的版本:

,您可以在主题的functions.php文件中使用这段代码:

  if(!function_exists('yith_wcan_frontend_classes')){function yith_wcan_frontend_classes(){return array('container'=>'YOUR_SHOP_CONTAINER','pagination'=>'YOUR_PAGINATION_CONTAINER','result_count'=> 'YOUR_RESULT_COUNT_CONTAINER'); add_filter('yith_wcan_ajax_frontend_classes','yith_wcan_frontend_classes');  

如果您不知道应该使用哪些课程,请向开发人员询问您的主题。

从版本2.3.0或更高版本:

您不必再手动编写代码,因为您可以转到YITH插件 – > Ajax产品过滤器 – >前端并轻松设置文本字段中的参数。

如果您不知道应该使用哪些课程,请向开发人员询问您的主题。

PAAMAYIM NEKUDOTAYIM更新后的错误2.1.0

在更新2.1.0之后,YITH WooCommerce Ajax产品过滤器的一些用户遇到错误:“解析错误:语法错误,意外T_PAAMAYIM_NEKUDOTAYIM”。这是由服务器的PHP版本早于5.3引起的。要解决此问题,您只需将插件更新到2.1.1版即可。

它与所有WordPress主题兼容吗?

与所有主题的兼容性是不可能的,因为它们太多了,但通常如果根据WordPress和WooCommerce指南开发主题,YITH插件与它们兼容。
然而,我们可以与YIThemes开发的主题兼容,因为它们不断更新并使用我们的插件进行测试。有时,特别是w新版本发布后,可能只需要一些时间让它们全部更新,但您可以确定它们将进行测试并将在几天内完成。

如果我的WooCommerce插件不起作用,我如何获得支持?

如果您的WooCommerce插件出现问题或者某些内容无法正常工作,请先按照以下步骤操作:

使用WordPress默认主题测试插件,以确保错误不是由主题引起的您正在使用。停用您正在使用的所有插件并检查问题是否仍在发生。确保您的插件版本,您的主题版本以及您的WordPress和WooCommerce版本(如果需要)已更新,并且您遇到的问题没有已经在以后的插件更新中解决了。

如果之前列出的所有操作都没有帮助您解决问题,那么请在论坛中提交故障单并准确描述您的问题,指定您正在使用的WordPress和WooCommerce版本以及可能有助于我们解决您的问题的任何其他信息。尽快。谢谢!

如何为我的WooCommerce插件获取更多功能?

您可以使用YITH WooCommerce Ajax产品过滤器的高级版本获得更多功能,可在 YIThemes页面上找到。在这里,您可以阅读有关该插件的高级功能的更多信息,并使其最佳拍摄!

如何试用功能齐全的插件?

如果您想查看高级插件的演示版,您可以在此页此页中看到它安装在两个不同的WooCommerce网站上。浏览它并尝试所有可用选项,以便您可以看到插件的外观。

评论

发表评论

电子邮件地址不会被公开。 必填项已用*标注