Members – WordPress plugin WordPress插件下载

点击下载

成员

插件描述

成员是一个扩展您对博客的控制权的插件。它是一个用户,角色和功能编辑器插件,旨在使WordPress成为更强大的CMS。

它通过为WordPress强大的角色和上限系统提供用户界面(UI)来控制您网站的权限,传统上只有知道如何手动编码的开发人员才能使用。

插件功能

角色编辑器:允许您编辑,创建和删除角色以及这些角色的功能。 多个用户角色:为任何用户提供一个,两个甚至更多角色。 明确拒绝功能:拒绝特定用户角色的特定上限。 克隆角色:通过克隆现有角色来构建新角色。 内容权限:使您可以控制哪些用户(按角色)有权发布内容。 Shortcodes:用于控制谁有权访问内容的短代码。 小部件:登录表单小部件和用户小部件,显示在主题的侧边栏中。 私人网站:如果需要,您可以将您的网站及其Feed全部设为私有。 插件集成:其他WordPress开发人员强烈推荐使用会员。许多现有插件将其自定义角色和封装直接集成到其中。

有关详细信息,请访问成员插件主页

喜欢这个插件?

会员插件是一个庞大的项目,需要维护1,000行代码。重大更新可能需要数周或数月的工作。我不直接从这个插件赚钱,而其他类似的插件收取大量费用甚至下载或获得更新。请考虑h通过以下方式解决问题:

捐款在我的网站注册。 评估插件

专业支持

如果您需要我的插件作者的专业插件支持,您可以访问 Theme Hybrid 的支持论坛,这是一个专业的WordPress帮助/支持网站,我处理了对75,000多个用户(并且不断增长)的社区的所有插件和主题的支持。

插件开发

如果您是主题作者,插件作者或代码爱好者,您可以在 GitHub存储库上关注此插件的开发。

屏幕截图

角色管理界面
编辑角色屏幕
内容权限元框(编辑帖子/页面屏幕)
插件设置屏幕
为每个用户选择多个角色(编辑用户界面)

安装

成员上传到 / wp-content / plugins / 目录。通过WordPress中的“插件”菜单激活插件。转到“设置>成员“选择您要使用的设置。

插件的 readme.html 文件中包含更详细的说明。

FAQ

安装说明上载成员 / wp-content / plugins / 目录。通过WordPress中的“插件”菜单激活插件。转到“设置>成员“选择您要使用的设置。

更详细的说明包括在内插件的 readme.html 文件。

为什么要创建此插件?

我对当前可用的用户,角色和权限插件不满意。是的,其中一些很好,但完全不符合我的想法。有些功能很少。有些完全在WordPress API之外工作。其他人缺乏GPL许可证。

所以,我刚刚建造了一些我真正喜欢使用的东西。

我该如何使用它?

大多数事情应该相当简单,但我在插件下载中包含了一个深入的指南。它是插件文件夹中名为 readme.md 的文件。

您也可以在线查看自述文件

最低PHP要求。

自成员2.1.0版以来,PHP 5.6+是使用该插件的软要求。该插件仍然适用于PHP 5.3+,但不推荐使用。

当发布成员版本3.0.0时,PHP 5.6+将是一项硬性要求,并且不适用于旧版本的PHP。

我无法访问“角色管理器”功能。

首次激活插件时,它会运行一个脚本,为您网站上的“管理员”角色设置特定功能,授予您访问此功能的权限。因此,您必须使用管理员帐户登录才能访问角色管理器。

如果出于某种原因,您确实具有管理员角色并且仍无法访问角色管理器,请停用该插件。然后,重新激活它。

在多站点上,为什么管理员无法管理角色?

如果您有多站点安装,则默认情况下只有超级管理员可以创建,编辑和删除角色。这是一种安全措施,可确保您绝对信任子站点管理员对角色进行这些类型的更改。如果您确定要允许此操作,请添加创建角色(创建ate_roles ),编辑角色( edit_roles )和/或删除角色( delete_roles )功能到您要允许的每个子站点上的角色。

注意:此更改是在2.0.2版本中进行的,对现有子站点上现有的成员安装没有影响。

帮助!我把自己锁在了我的网站之外!

请在实际使用之前阅读该插件的文档,尤其是控制您网站权限的插件。我不能强调这一点。这是一个功能强大的插件,允许您直接更改数据库中的角色和功能。

您需要在我的支持论坛之前停止,看看如果您设法锁定自己,我们是否可以修复您的网站。我知道这可能有点可怕,但用一些自定义代码修复并不难。

评论

发表评论

电子邮件地址不会被公开。 必填项已用*标注