AMP – WordPress plugin WordPress插件下载

点击下载

AMP

插件描述

AMP项目是一项开源计划,旨在让所有人都能更好地使用网络。 AMP支持跨分发平台持续快速,美观且高性能的Web体验。适用于WordPress的官方AMP插件支持WordPress网站的完全集成的AMP发布,具有强大的功能和精细的发布者控件。

插件提供的功能包括:

兼容性工具:通过启用AMP调试以及可能存在的验证错误的详细信息来帮助开发AMP体验,​​标记/脚本导致它们,以及负责该页面内容的站点上的特定组件(例如主题,插件,核心)。 CSS Tree Shaking :帮助处理网站上定义的CSS规则超过单个AMP页面允许的CSS大小限制的情况。 核心主题支持:为四个默认主题(即二十五,二十六,二十七,二十九)启用完整的AMP有效性。 Gutenberg支持:使AMP内容创建与Gutenberg完全集成。 AMP-first Experiences支持:在不牺牲平台灵活性或内容保真度的情况下实现全站点AMP体验。 许多优化:无数的代码,性能和开发人员体验改进:从定制灵活性到更好的UI流程,国际化,可访问性等。

使用WordPress的官方AMP插件,WordPress生态系统提供构建世界级AMP体验所需的功能和工具,而不偏离其标准,灵活和众所周知的内容创建工作流程。

使用入门

要了解有关插件的更多信息并开始利用其功能为AMP内容创建工作流程提供支持,请检查官方AMP插件产品网站

如果您是开发人员,我们建议您按照贡献在GitHub上开发此插件。

屏幕截图

主题支持使您可以重复使用活动主题的模板和样式表; AMP中提供了所有WordPress功能(菜单,小部件,注释)。
许多主题可以作为AMP而不做任何更改;默认体验就像在浏览器中关闭JavaScript一样,因为删除了脚本。
经典模板仍然可用,但它们是有限的。它们不仅与活动主题不同,任何验证错误都会被静默消毒。
在AMP设置屏幕中从经典模式切换为配对模式或本机模式。如果您的主题有更多的CSS,您可能需要在AMP中禁用管理栏。
在AMP中提供整个网站或选择特定的帖子类型和模板;您也可以选择退出每个帖子。
插件检查AMP的有效性,并指示何时发现:未发现问题,新问题需要审核,或发出阻止AMP服务的问题。
编辑器将在内容创作过程中显示验证问题。指示具有验证错误的特定块。
验证的URL包括遇到的验证错误列表,可控制是否对验证进行清理n错误被接受或拒绝。
按主题和插件添加的样式会自动连接,缩小和树形摇动,以保持总内容不超过50KB的内联CSS。
提供WP-CLI命令以检查站点上的URL是否有效。管理员可以在检查中获得结果。

安装

将文件夹上传到 / wp-content / plugins / 目录。通过WordPress中的“插件”菜单激活插件。如果您当前使用较旧版本经典模式中的插件版本,强烈建议您迁移到已配对纯模式

评论

发表评论

电子邮件地址不会被公开。 必填项已用*标注